User Tools

Site Tools


build:dependencies:linux

Linux

Prerequisites

sudo apt-get install autoconf2.13 yasm libgtk2.0-dev libglib2.0-dev libdbus-1-dev libdbus-glib-1-dev libasound2-dev libcurl4-openssl-dev libiw-dev libxt-dev mesa-common-dev libpulse-dev help2man libffi-dev texinfo

Clone the Repo

Install Bundled Packages

sudo dpkg -i packages/linux/automake_1.14.1-2ubuntu1_all.deb

Automake 1.14 should be in the installable via apt with Ubuntu 14.04?

Automated Build (not including XR)

Simply run:

./build-no-xul.sh

Notes

If you're using GCC 4.8, you may run into a problem when building Nightingale itself because of conflicting declarations in the newer XR and system headers.

https://gist.github.com/johnmurrayvi/5879822

TODO: Figure out a better fix when I get a chance.

build/dependencies/linux.txt · Last modified: 2014/03/20 11:31 by johnmurrayvi